OM/YL Online  

   

Login  

   

donazione  

 
   Donazione a sostegno e per lo
      sviluppo
del Club Italiano
                Modi Digitali
               Psktrentunisti

   

MultiTrans  

   
   
Benvenuto, Ospite
Nome utente: Password: Ricordami

ARGOMENTO: modifica modem Pirelli

modifica modem Pirelli 4 Anni 11 Mesi fa #869

  • soulribel
  • Avatar di soulribel
  • OFFLINE
  • Moderatore
  • Messaggi: 100
  • Ringraziamenti ricevuti 22
  • Karma: 22
Oggi giorno tutti nelle nostre case usufruiamo di una serie di accessori e confort,come altri utenti di questo forum (vedi alimentatori pc), anche io ho deciso di dare nuova vita e un nuovo impiego a qualche hardware oramai rimpiazzato.
Nel mio caso ho modificato e adattato al mio scopo un vecchio modem del lontano 2007. Il modem in questione è di produzione Pirelli DRG-a226m girovagando sulla rete ho trovato una guida su come sostituire il software interno e caricarci su linux rendendolo modificabile e flessibile a tutti gli usi.(suddivido questa guida in più step così da non far confondere chi per la prima volta smanetti con queste cose, premetto che una volta caricato il software linux sopra per tornare indietro serve un'immagine originale, ma considerando che sicuramente chi lo farà avrà un modem buttato in cantina non credo gli interessi tornare indietro :woohoo: )
Per la modifica sono necessari un modem pirelli ( anche i modem alice gate vanno bene o quelli fastweb) un cavetto seriale per cellulari siemens, io personalmente ho comprato un adattatore ttl rs232 basato sull'ovvio MAX232 ovviamente serve un pc, una connessione internet, un cavo di rete e le classiche cose che sono nel laboratorio di tutti ovvero saldatore, stagno ecc ecc.
Bene direi che possiamo iniziare! Smontiamo il nostro bel modem, ed estraiamo la scheda, il prossimo passo ora sta nel trovare 6 piazzole di rame libere ( la posizione di esse varia da modello a modello,) nel mio caso sono sopra il processore
Questa immagine è nascosta ai visitatori. Prego accedi o registrati per visualizzarli.

nella foto trovate già segnati i pin che ci servono tx,rx,vcc,gnd.
Una volta individuate le piazzole, provvediamo a saldare 4 pin o pezzetti di filo rigido ( io ho usato 4 pin recuperati da una vecchia scheda madre) e colleghiamo il nostro adattatore.
Questa immagine è nascosta ai visitatori. Prego accedi o registrati per visualizzarli.

Sul nostro pc occorre scaricare tre piccoli programmini oltre al file immagine del software che dovremmo inserire nel modem:
teraterm
tftpd32
putty
e la nostra immagine da caricarci su ovvero Openwrt
nel mio caso scarico una versione adatta al mio modem ovvero la Backfire 10.03.1.
Continua.....
Ultima modifica: 4 Anni 11 Mesi fa da soulribel.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.
I seguenti utenti ringraziano:: iz8ifl

modifica modem Pirelli 4 Anni 11 Mesi fa #870

  • soulribel
  • Avatar di soulribel
  • OFFLINE
  • Moderatore
  • Messaggi: 100
  • Ringraziamenti ricevuti 22
  • Karma: 22
Per vedere quale immagina di Openwrt caricare sul vostro modem vi aggiungo qui la lista dei modem esistenti e modificabili con questa piattaforma free troverete marca modello le specifiche tecniche e la versione di openwrt da usare e altre info utili al flash
lista dispositivi compatibili
aggiungo qui i link ai programmi necessari:
teraterm pro2.3 non il resto
tftpd32
Putty

Questa immagine è nascosta ai visitatori. Prego accedi o registrati per visualizzarli.
Ultima modifica: 4 Anni 11 Mesi fa da soulribel.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.
I seguenti utenti ringraziano:: iz8ifl

modifica modem Pirelli 4 Anni 11 Mesi fa #871

  • iz8ifl
  • Avatar di iz8ifl
  • ADESSO ONLINE
  • Amministratore
  • Messaggi: 527
  • Ringraziamenti ricevuti 108
  • Karma: 20
Paolo intanto complimenti per questo lavoro :)
Una domanda ma poi questo nuovo firmware che andiamo ad inserire nel modem migliora le sue prestazioni oppure aggiunge nuove funzionalità al modem?
Se puoi aggiungere qualche schermata con il nuovo software e qualche altra informazione te ne saremmo grati.
ciao Salvatore
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

modifica modem Pirelli 4 Anni 11 Mesi fa #874

  • soulribel
  • Avatar di soulribel
  • OFFLINE
  • Moderatore
  • Messaggi: 100
  • Ringraziamenti ricevuti 22
  • Karma: 22
Carissimo! Il software Openwrt oltre ad essere più stabile è molto più flessibile rispetto all'originale in questa guida oltre a spiegare come caricarlo sul modem posterò due prove già fatte, un ripetitore wifi, e realizzare un sistema streaming di una webcam, che è ciò che mi serve per il rover, ma utilizzando le varie estensioni ad esempio trasformare una stampante usb in una vera stampante di rete, o utilizzare una chiavetta internet per ottenere un router wifi o diventare un vero e proprio robot, utilizzando python
robot
Ultima modifica: 4 Anni 11 Mesi fa da soulribel.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.

modifica modem Pirelli 4 Anni 11 Mesi fa #876

  • soulribel
  • Avatar di soulribel
  • OFFLINE
  • Moderatore
  • Messaggi: 100
  • Ringraziamenti ricevuti 22
  • Karma: 22
Una volta saldati i nostri 4 pin e collegato il nostro adattatore direi di procedere a caricare Openwrt, supponendo di aver già scaricato i tre programmi + il file immagine adatto lasciando il modem spento lo colleghiamo al pc tramite cavo rete alla prima porta lan del modem e alla porta lan del pc, colleghiamo anche il cavo seriale e settiamo il tutto così:
impostiamo la nostra scheda di rete del pc assegnando un ip statico della serie 192.168.1.xxx dove "xxx" sarà un numero scelto da voi (e diverso da 192.168.1.1)
Questa immagine è nascosta ai visitatori. Prego accedi o registrati per visualizzarli.
ad esempio

Bene fatto questo salvate le modifiche alla scheda lan e aprite teraterm.
Nella schermata iniziale vi chiederà il tipo di connessione scegliete seriale ovviamente
Questa immagine è nascosta ai visitatori. Prego accedi o registrati per visualizzarli.

Andate su impostazioni della porta seriale di teraterm e modificate solo la velocità su 115200

Questa immagine è nascosta ai visitatori. Prego accedi o registrati per visualizzarli.


Questa immagine è nascosta ai visitatori. Prego accedi o registrati per visualizzarli.

Aprite ora tftpd32 e selezionate la vostra scheda di rete come in figura

Questa immagine è nascosta ai visitatori. Prego accedi o registrati per visualizzarli.

ora che tutto è settato possiamo procedere al flash!
Date alimentazione al modem e vedrete su Teraterm le info di boot, premete il tasto invio rapidamente non appena inizia il boot e sul terminale vi apparirà la scritta "CFE>", andate su tftpd32 senza chiudere teraterm, e selezionate la directory dove avete salvato la vostra immagine di openwrt sfogliate fino a trovarla e copiatela poi da terminale digitate il comando:
"flashimage l'ip della scheda di rete:openwrt-il-nome-esatto-del-file.bin" premendo invio se tutto è corretto inizia la procedura
potete sorseggiare un the magari o un caffè, al vostro ritorno troverete le nuove info di boot sul terminale e premendo invio attiverete la console e vi apparirà la classica scritta Openwrt!
Al momento però risulta impossibile accedere al modem se non da Telnet o teraterm per accedere da putty bisogna inserire la password!
Per inserire la password sul modem abbiamo due modi, il primo da Teraterm ma l'ambiente è un pò ostico e a volte succede che impazzisca, épiù sicuro e facile da Telnet! Apriamo il prompt dei comandi e digitiamo" telnet( invio) open 192.168.1.1
non appena richiede il login scriviamo root.
Bene siamo dentro all'interfaccia openwrt, digitiamo adesso il comando " passwd" e digitiamo due volte la password scelta, fatto questo possiamo chiudere tutti i programmi aperti scollegare l'adattatore seriale e reimpostare di nuovo la nostra scheda lan del pc, il modem darà un ip da solo.
Avviamo putty
Questa immagine è nascosta ai visitatori. Prego accedi o registrati per visualizzarli.

inseriamo il nostro ip ovvero 192.168.1.1 e avviamo la connessione ci richiederà nuovamente i dati di accesso quindi "root + la pass che avete impostato"
prima di procedere oltre dobbiamo effettuare urgentemente una modifica al nostro modem, sopratutto se dovrà connettersi tramite un'altro modem ovvero cambiare l'indirizzo ip suo (192.168.1.1)
Da putty digitate "vi /etc/config/network" premendo invio entriamo sulla sezione lan del modem per modificarla basta premere la "i" e configuratela così:
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option type bridge
option ifname eth0
option proto static
option ipaddr 192.168.1.155(ip del modem inserite uno che vi ricordiate)
option netmask 255.255.255.0
option gateway 192.168.1.1 ( ip del modem dove ci collegheremo se è alice!)
option dns 212.216.112.112 (idem i dns sono di alice)
option nat 1

config interface wan
option ifname eth1
option proto dhcp
per salvare ed uscire premete una volta "esc"per bloccare il cursore di scrittura, poi premiamo shift + z tutti e tre contemporaneamente fino quando non ritorniamo alla home.
Il wifi in origine è disattivato quindi per poterci connettere dobbiamo attivarlo,
digitiamo "vi /etc/config/wireless premiamo invio e modifichiamo solo il numero da "1" a "0" su " option disable"
salviamo e digitiamo reboot, a boot completato spegniamo tutto scolleghiamo il cavo di rete e colleghiamo il modem via lan al modem di casa, successivamente da pc cerchiamo via wireless la rete nominata openwrt e vi accediamo, riapriamo putty e testiamo la connessione internet digitando il seguente comando: "opkg update" premendo invio se è presente la connessione verrà scaricata la lista dei pacchetti!
Complimenti a chi è arrivato fin qui al primo colpo! Nel prossimo post realizzeremo un ripetitore wifi e aggiungeremo una nuovo volto alla grafica del modem,
Ultima modifica: 4 Anni 11 Mesi fa da soulribel.
L\'Amministratore ha disattivato l\'accesso in scrittura al pubblico.
I seguenti utenti ringraziano:: giopape
Tempo creazione pagina: 0.448 secondi
Powered by Forum Kunena
   
   
© PSKTRENTUNISTI ITALIAN CLUB (PIC)